$re = '/\d+(\s*,\s*\d+)*|\bs\..*$/im';
$str = 'Lorem ipsum 12, 14
Lorem 29
34
Lorem s. anything
vcbvcbv';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;