const regex = /\d+(\s*,\s*\d+)*|\bs\..*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(\\s*,\\s*\\d+)*|\\bs\\..*$', 'gim')
const str = `Lorem ipsum 12, 14
Lorem 29
34
Lorem s. anything
vcbvcbv`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);