# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+(\s*,\s*\d+)*|\bs\..*$"
test_str = ("Lorem ipsum 12, 14\n"
"Lorem 29\n"
"34\n"
"Lorem s. anything\n"
"vcbvcbv")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.