import Foundation
let pattern = #"\d+(\s*,\s*\d+)*|\bs\..*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Lorem ipsum 12, 14
Lorem 29
34
Lorem s. anything
vcbvcbv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)