// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\d+(\s*,\s*\d+)*|\bs\..*$").unwrap();
let string = "Lorem ipsum 12, 14
Lorem 29
34
Lorem s. anything
vcbvcbv";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}