#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(".[>].*?")|<i3dMapping id=(?P<name>".*?") node=(".[>].*?")"
Local $sString = "<movingPart index="0>8|1|3" referencePoint="0>8|1|0|4" referenceFrame="0>" scaleZ="true"/>" & @CRLF & _
"bla" & @CRLF & _
"bla" & @CRLF & _
"<i3dMapping id="KroneComprimaV180XC" node="0>" />" & @CRLF & _
"<i3dMapping id="novoGripPart2_fixPoint" node="0>8|1|0|4" />" & @CRLF & _
"<i3dMapping id="novoGrip_part2" node="0>8|1|3" />"
Local $sSubst = "\k'name'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)