# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\".[>].*?\")|<i3dMapping id=(?P<name>\".*?\") node=(\".[>].*?\")"
test_str = ("<movingPart index=\"0>8|1|3\" referencePoint=\"0>8|1|0|4\" referenceFrame=\"0>\" scaleZ=\"true\"/>\n"
"bla\n"
"bla\n"
"<i3dMapping id=\"KroneComprimaV180XC\" node=\"0>\" />\n"
"<i3dMapping id=\"novoGripPart2_fixPoint\" node=\"0>8|1|0|4\" />\n"
"<i3dMapping id=\"novoGrip_part2\" node=\"0>8|1|3\" />")
subst = "\\k'name'"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.