// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(".[>].*?")|<i3dMapping id=(?P<name>".*?") node=(".[>].*?")"#).unwrap();
let string = "<movingPart index=\"0>8|1|3\" referencePoint=\"0>8|1|0|4\" referenceFrame=\"0>\" scaleZ=\"true\"/>
bla
bla
<i3dMapping id=\"KroneComprimaV180XC\" node=\"0>\" />
<i3dMapping id=\"novoGripPart2_fixPoint\" node=\"0>8|1|0|4\" />
<i3dMapping id=\"novoGrip_part2\" node=\"0>8|1|3\" />";
let substitution = "\\k'name'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}