const regex = /(".[>].*?")|<i3dMapping id=(?P<name>".*?") node=(".[>].*?")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(".[>].*?")|<i3dMapping id=(?P<name>".*?") node=(".[>].*?")', 'gm')
const str = `<movingPart index="0>8|1|3" referencePoint="0>8|1|0|4" referenceFrame="0>" scaleZ="true"/>
bla
bla
<i3dMapping id="KroneComprimaV180XC" node="0>" />
<i3dMapping id="novoGripPart2_fixPoint" node="0>8|1|0|4" />
<i3dMapping id="novoGrip_part2" node="0>8|1|3" />`;
const subst = `\k'name'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);