re = /(".[>].*?")|<i3dMapping id=(?P<name>".*?") node=(".[>].*?")/m
str = '<movingPart index="0>8|1|3" referencePoint="0>8|1|0|4" referenceFrame="0>" scaleZ="true"/>
bla
bla
<i3dMapping id="KroneComprimaV180XC" node="0>" />
<i3dMapping id="novoGripPart2_fixPoint" node="0>8|1|0|4" />
<i3dMapping id="novoGrip_part2" node="0>8|1|3" />'
subst = '\\k\'name\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result