import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\".[>].*?\")|<i3dMapping id=(?P<name>\".*?\") node=(\".[>].*?\")";
final String string = "<movingPart index=\"0>8|1|3\" referencePoint=\"0>8|1|0|4\" referenceFrame=\"0>\" scaleZ=\"true\"/>\n"
+ "bla\n"
+ "bla\n"
+ "<i3dMapping id=\"KroneComprimaV180XC\" node=\"0>\" />\n"
+ "<i3dMapping id=\"novoGripPart2_fixPoint\" node=\"0>8|1|0|4\" />\n"
+ "<i3dMapping id=\"novoGrip_part2\" node=\"0>8|1|3\" />";
final String subst = "\\k'name'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}