using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("".[>].*?"")|<i3dMapping id=(?P<name>"".*?"") node=("".[>].*?"")";
string substitution = @"\k'name'";
string input = @"<movingPart index=""0>8|1|3"" referencePoint=""0>8|1|0|4"" referenceFrame=""0>"" scaleZ=""true""/>
bla
bla
<i3dMapping id=""KroneComprimaV180XC"" node=""0>"" />
<i3dMapping id=""novoGripPart2_fixPoint"" node=""0>8|1|0|4"" />
<i3dMapping id=""novoGrip_part2"" node=""0>8|1|3"" />";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}