#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\s*a\s*[^>]*href\s*=\s*"([^"]+)""
Local $sString = "" & @CRLF & _
"some text" & @CRLF & _
"" & @CRLF & _
"<a href="normal/link/here.html">" & @CRLF & _
"" & @CRLF & _
"< a" & @CRLF & _
" class="some other attribute"" & @CRLF & _
" href = "strange/whitespaces/in/this/tag.html"" & @CRLF & _
">" & @CRLF & _
"" & @CRLF & _
"<div><p>some other tags</p></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")