// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<\s*a\s*[^>]*href\s*=\s*"([^"]+)""#).unwrap();
let string = "
some text
<a href=\"normal/link/here.html\">
< a
class=\"some other attribute\"
href = \"strange/whitespaces/in/this/tag.html\"
>
<div><p>some other tags</p></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}