package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*a\s*[^>]*href\s*=\s*"([^"]+)"`)
var str = `
some text
<a href="normal/link/here.html">
< a
class="some other attribute"
href = "strange/whitespaces/in/this/tag.html"
>
<div><p>some other tags</p></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}