const regex = /<\s*a\s*[^>]*href\s*=\s*"([^"]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*a\\s*[^>]*href\\s*=\\s*"([^"]+)"', 'g')
const str = `
some text
<a href="normal/link/here.html">
< a
class="some other attribute"
href = "strange/whitespaces/in/this/tag.html"
>
<div><p>some other tags</p></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}