using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*a\s*[^>]*href\s*=\s*""([^""]+)""";
string input = @"
some text
<a href=""normal/link/here.html"">
< a
class=""some other attribute""
href = ""strange/whitespaces/in/this/tag.html""
>
<div><p>some other tags</p></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}