$re = '/<\s*a\s*[^>]*href\s*=\s*"([^"]+)"/';
$str = '
some text
<a href="normal/link/here.html">
< a
class="some other attribute"
href = "strange/whitespaces/in/this/tag.html"
>
<div><p>some other tags</p></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);