import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*a\\s*[^>]*href\\s*=\\s*\"([^\"]+)\"";
final String string = "\n"
+ "some text\n\n"
+ "<a href=\"normal/link/here.html\">\n\n"
+ "< a\n"
+ " class=\"some other attribute\"\n"
+ " href = \"strange/whitespaces/in/this/tag.html\"\n"
+ ">\n\n"
+ "<div><p>some other tags</p></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}