re = /<\s*a\s*[^>]*href\s*=\s*"([^"]+)"/
str = '
some text
<a href="normal/link/here.html">
< a
class="some other attribute"
href = "strange/whitespaces/in/this/tag.html"
>
<div><p>some other tags</p></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end