# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<c>.*?<\/c>/ /siug;t' <<< "a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae"