use strict;
my $str = 'a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae';
my $regex = qr~<c>.*?</c>~siup;
my $subst = ' ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";