re = /<c>.*?<\/c>/i
str = 'a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result