using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<c>.*?</c>";
string substitution = @" ";
string input = @"a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}