// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?siu)<c>.*?</c>").unwrap();
let string = "a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}