# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<c>.*?</c>"
test_str = "a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae"
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.IGNORECASE | re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.