$re = '~<c>.*?</c>~siu';
$str = 'a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;