package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)<c>.*?</c>`)
var str = `a<b>z</b>c<u>d</u>e<c>aa<div>a</div>aaa</c>aaa<br>aaaaaaae`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}