# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\\/.*\\/)(\d{3,})(.*)/$1{id}$3 \/\/ dont print the $2!/gi;t' <<< "/product/1234567890/warranty"