use strict;
my $str = '/product/1234567890/warranty';
my $regex = qr/^(\/.*\/)(\d{3,})(.*)/ip;
my $subst = '$1{id}$3 // dont print the $2!';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";