// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^(\/.*\/)(\d{3,})(.*)").unwrap();
let string = "/product/1234567890/warranty";
let substitution = "$1{id}$3 // dont print the $2!";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}