re = /^(\/.*\/)(\d{3,})(.*)/i
str = '/product/1234567890/warranty'
subst = '$1{id}$3 // dont print the $2!'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result