import Foundation
let pattern = #"^(\/.*\/)(\d{3,})(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"/product/1234567890/warranty"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1{id}$3 // dont print the $2!"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)