#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)^(\/.*\/)(\d{3,})(.*)"
Local $sString = "/product/1234567890/warranty"
Local $sSubst = "$1{id}$3 // dont print the $2!"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)