$re = '/^(\/.*\/)(\d{3,})(.*)/i';
$str = '/product/1234567890/warranty';
$subst = "$1{id}$3 // dont print the $2!";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;