# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(\w+):\s?(\w+.\w+)]/<$1 src='$2' \/>/g;t' <<< "[img: something.jpg]"