re = /\[(\w+):\s?(\w+.\w+)]/
str = '[img: something.jpg]'
subst = '<$1 src=\'$2\' />'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result