#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(\w+):\s?(\w+.\w+)]"
Local $sString = "[img: something.jpg]"
Local $sSubst = "<$1 src='$2' />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)