const regex = /\[(\w+):\s?(\w+.\w+)]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\w+):\\s?(\\w+.\\w+)]', 'g')
const str = `[img: something.jpg]`;
const subst = `<$1 src='$2' />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);