use strict;
my $str = '[img: something.jpg]';
my $regex = qr/\[(\w+):\s?(\w+.\w+)]/p;
my $subst = '<$1 src=\'$2\' />';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";