import Foundation
let pattern = #"\[(\w+):\s?(\w+.\w+)]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[img: something.jpg]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1 src='$2' />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)