package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(\w+):\s?(\w+.\w+)]`)
var str = `[img: something.jpg]`
var substitution = "<$1 src='$2' />"
fmt.Println(re.ReplaceAllString(str, substitution))
}