#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<propName>[A-Za-z0-9_.-]+)(?<assign>\s*(?:=|:)\s*)(?<propVal>(?:[^\r\n\\]++|\\(?:\r?\n|\r|.))*+$)"
Local $sString = "DAOSomething.classe " & @CRLF & _
"= " & @CRLF & _
"com.theCompagny.theProject.theFeature.dao.\" & @CRLF & _
"impl.DAOSomethingImpl" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"channel = bla\" & @CRLF & _
"bla \" & @CRLF & _
"bla" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")