re = /(?<propName>[A-Za-z0-9_.-]+)(?<assign>\s*(?:=|:)\s*)(?<propVal>(?:[^\r\n\\]++|\\(?:\r?\n|\r|.))*+$)/m
str = 'DAOSomething.classe
=
com.theCompagny.theProject.theFeature.dao.\\
impl.DAOSomethingImpl
channel = bla\\
bla \\
bla
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end