const regex = /(?<propName>[A-Za-z0-9_.-]+)(?<assign>\s*(?:=|:)\s*)(?<propVal>(?:[^\r\n\\]++|\\(?:\r?\n|\r|.))*+$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<propName>[A-Za-z0-9_.-]+)(?<assign>\\s*(?:=|:)\\s*)(?<propVal>(?:[^\\r\\n\\\\]++|\\\\(?:\\r?\\n|\\r|.))*+$)', 'mg')
const str = `DAOSomething.classe
=
com.theCompagny.theProject.theFeature.dao.\\
impl.DAOSomethingImpl
channel = bla\\
bla \\
bla
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}