import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<propName>[A-Za-z0-9_.-]+)(?<assign>\\s*(?:=|:)\\s*)(?<propVal>(?:[^\\r\\n\\\\]++|\\\\(?:\\r?\\n|\\r|.))*+$)";
final String string = "DAOSomething.classe \n"
+ "= \n"
+ "com.theCompagny.theProject.theFeature.dao.\\\n"
+ "impl.DAOSomethingImpl\n\n\n"
+ "channel = bla\\\n"
+ "bla \\\n"
+ "bla\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}