// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<propName>[A-Za-z0-9_.-]+)(?<assign>\s*(?:=|:)\s*)(?<propVal>(?:[^\r\n\\]++|\\(?:\r?\n|\r|.))*+$)").unwrap();
let string = "DAOSomething.classe
=
com.theCompagny.theProject.theFeature.dao.\\
impl.DAOSomethingImpl
channel = bla\\
bla \\
bla
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}