package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<propName>[A-Za-z0-9_.-]+)(?<assign>\s*(?:=|:)\s*)(?<propVal>(?:[^\r\n\\]++|\\(?:\r?\n|\r|.))*+$)`)
var str = `DAOSomething.classe
=
com.theCompagny.theProject.theFeature.dao.\
impl.DAOSomethingImpl
channel = bla\
bla \
bla
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}