import Foundation
let pattern = #"(?<propName>[A-Za-z0-9_.-]+)(?<assign>\s*(?:=|:)\s*)(?<propVal>(?:[^\r\n\\]++|\\(?:\r?\n|\r|.))*+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DAOSomething.classe
=
com.theCompagny.theProject.theFeature.dao.\
impl.DAOSomethingImpl
channel = bla\
bla \
bla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)