# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=.*(\b\w{3}\b))(?=.*(\b\d{4}\b)).*/$1-$2/gim;t' <<< "Oct-2013
2013-Oct"